Ошибка 1с EDT: Версия JVM не подходит для данного продукта

Всем привет. На днях ставил 1с EDT и при запуске наткнулся на такую ошибку ‘Version 1.8.0_212 of the JVM is not suitable for this product. Version: 11 or greater is required.’:

Version 1.8.0_212 of the JVM is not suitable for this product. Version: 11 or greater is required.
Version 1.8.0_212 of the JVM is not suitable for this product. Version: 11 or greater is required.

Переходим на сайт обновлений 1с, где мы скачивали EDT и читаем системные требования, где черным по белому написано:

Системные требования 1с EDT.
Системные требования 1с EDT.
Системные требования к java.
Системные требования к java.

Если ввкратце, то для корректной работы 1с EDT нам необходим дистрибутив ‘OpenJDK’, в состав сборки которого должен входить ‘OpenJFX(JavaFX)’. Сайт 1с рекомендует скачивать его с сайта ‘https://libericajdk.ru/‘:

Комплект разработчика liberica-jdk.
Комплект разработчика liberica-jdk.

Скачиваем необходимую нам 11 версию и устанавливаем её:

java-11.0.7.
java-11.0.7.

После чего 1с EDT начинает работать корректно, без всяких ошибок. Все нюансы установки есть на сайте 1с, оказывается просто нужно читать мануалы (коим я иногда брезговал):

Мануал установки 1c EDT.
Мануал установки 1c EDT.

Всем удачной работы в 1с EDT!Пока.

1+

Оставить комментарий

Ваш адрес email не будет опубликован.